Une erreur inattendue s'est produite. Quelque chose ne va pas avec WordPress.org ou la configuration de ce serveur

11

J'utilise WordPress sur un serveur WAMP localhost et chaque fois que je vais dans "Plugins" ou "Tableau de bord > Mises à jour" ou même dans "Tableau de bord", rien ne se charge (pas de nouvelles de WordPress, pas de mises à jour et je ne suis pas en mesure de le faire.) rechercher des plugins ni les mettre à jour).

Dans la section "Plugins", je vois ceci lorsque j'essaie de rechercher quelque chose:

  

Une erreur inattendue s'est produite. Quelque chose ne va pas avec   WordPress.org ou la configuration de ce serveur. Si vous continuez à avoir   problèmes, veuillez essayer les forums de support.

Quelqu'un at-il rencontré ce problème auparavant? Cela s'est passé du jour au lendemain il y a quelques semaines pour moi. Cela a fonctionné pendant longtemps et puis un jour il s'est arrêté. Ce que j'ai déjà fait:

  • Recherche dans les forums d'assistance Google et WordPress.org. Ce problème est mentionné des centaines de fois et il n’ya pas de solution.
  • Vérifié php.ini, la configuration d'Apache, .htaccess, a activé les modules PHP / Apache potentiellement associés, et a vérifié si WAMP est défini sur "en ligne" (mon WAMP est maintenant accessible depuis d'autres ordinateurs du réseau).
  • Autorisé toutes les autorisations pour WAMP dans "Autoriser un programme via le pare-feu Windows".
  • Désactive tous les plugins et thèmes autres que celui par défaut.
  • Vérifié [Paramètres > Général] pour voir si les URL sont valides et elles le sont.
  • Réenregistrer [Paramètres > Permaliens].
  • Vous avez installé un autre WordPress sur cet hôte local et cela fonctionne . Alors, pourquoi ne pas le premier?
posée Paul 25.10.2013 - 11:30

10 réponses

4

Dans mon cas, c’était simplement l’URL du SITE laissée en blanc dans Paramètres - > Général. je l'a rempli avec l'URL de mon site et tout a recommencé à fonctionner.

J'ai découvert cette information en activant WP_DEBUG dans le fichier wp-config.php. Cette erreur s'est produite: "Remarque: index non défini: hôte"

    
réponse donnée jim.duck 26.08.2015 - 15:42
2

Pour moi, le problème était que mon logiciel localhost (MAMP, sur macOS) n’était pas en mesure d’établir une connexion sécurisée. Après avoir activé WP_DEBUG et vérifié le fichier journal, l’erreur suivante a été relevée (soulignement ajouté par moi):

  

Avertissement PHP: Une erreur inattendue s'est produite. Quelque chose peut être faux   avec WordPress.org ou la configuration de ce serveur. Si vous continuez à   avoir des problèmes, s'il vous plaît essayer les forums de support. ( WordPress   Impossible d'établir une connexion sécurisée à WordPress.org . S'il vous plaît   contactez votre administrateur de serveur.) dans wp-includes / update.php

Après quelques recherches, j'ai trouvé un site disant que mon extension PHP cURL pourrait être désactivée. J'ai créé une page phpinfo () à vérifier; il était déjà activé.

Ensuite, j’ai trouvé un autre site disant que MAMP était livré avec une bibliothèque libcurl à laquelle manque un bundle ca-cert. Je vais copier le contenu de la page ici, juste au cas où cette page durerait plus longtemps:)

  

Si vous utilisez MAMP et utilisez quelque chose avec cURL, il y a de strongs chances que   vous rencontrerez l'erreur suivante:

     

Erreur CURL (60): problème de certificat SSL, vérifiez que le certificat de l'autorité de certification est   D'ACCORD. Détails: erreur: 14090086: SSL   routines: SSL3_GET_SERVER_CERTIFICATE: échec de la vérification du certificat

     

Ne vous inquiétez pas: MAMP est fourni avec la bibliothèque Curl qui semble manquer de   Ensemble ca-cert, que nous allons résoudre en recompilant simplement libcurl MAMP   utilise

     

Alors, faisons ce qui suit:

     
  1. Exécuter / Applications / MAMP / Bibliothèque / bin / curl-config --version pour voir laquelle   la version que vous avez

  2.   
  3. Accédez à enlace et téléchargez-le.   la bonne version

  4.   
  5. Configurez-le avec ./configure   --prefix = / Applications / MAMP / Bibliothèque /

  6.   
  7. make & & faire installer

  8.   

Si tout s'est bien passé, redémarrez simplement MAMP et l'erreur devrait disparaître

Copié à partir de enlace

.     
réponse donnée kayge 25.04.2018 - 21:47
1

Eh bien, même si vous aviez un problème similaire, cela a été résolu en suivant les étapes.
1) Connectez-vous à "Cpanel" de votre hébergement
2) Allez sur "Bilans de santé et surveillance"
3) Cliquez sur "Port 80"
4) Vérifiez si elle est bloquée,
   a) OUI > > Supprimer les fichiers susceptibles d'y figurer.
   b) NON > > Contactez votre support d'hébergement.
5) Si 4a > > Cliquez sur le déblocage du port, cela peut prendre quelques minutes à la minute pour être débloqué.

    
réponse donnée user3727574 04.10.2016 - 22:51
0

Après avoir passé plus de temps, est-ce que j’ai résolu ce problème en regardant

wp-config.php

Assurez-vous que cet indicateur est faux, si c'est vrai, la mise à jour ne pourrait pas se produire

define('WP_HTTP_BLOCK_EXTERNAL', false);
    
réponse donnée HMagdy 20.07.2017 - 11:35
0

Rencontré le même problème. Le tableau de bord se chargeait bien, seules les sections "Thèmes" et "plugins" étaient très lentes.

Nous avons découvert qu'il s'agissait simplement d'un problème de DNS après avoir vérifié auprès de nslookup , ce qui m'a donné ceci:

Server:     127.0.0.53
Address:    127.0.0.53#53

au lieu de mon adresse IP actuelle.

Résolu en faisant ceci:

sudo rm -f /etc/resolv.conf
sudo ln -s /run/systemd/resolve/resolv.conf /etc/resolv.conf
reboot 
    
réponse donnée Steve DeSousa 22.06.2018 - 10:57
-1

Essayez d’exécuter une requête ping sur wordpress.org, insérez une entrée DNS dans /etc/resolv.conf

    
réponse donnée John Ian Medilo 13.02.2017 - 17:34
-1

Modifiez wp_config.php et ajoutez le code suivant au bout du fichier:

define('FS_METHOD', 'direct');

Cela devrait permettre l'installation de plugins et de thèmes directement à partir du référentiel en ligne.

    
réponse donnée Infamous 07.08.2017 - 03:45
-1

Accédez à la cette page télécharger le fichier zip du plug-in et l'installer puis l'activer.

Allez sur votre tableau de bord WordPress, cliquez sur Éditeur WPCF, Ouvrir le proxy sur onglets.

Définissez votre proxy HTTP.

Au moins ça marche sur le mien.

    
réponse donnée Anon 13.01.2018 - 14:16
-1

Définissez simplement l'URL de votre site dans le fichier wp_config , par exemple:

define( 'WP_SITEURL', 'http://localhost/your_site' );
define( 'WP_HOME', 'http://localhost/your_site' );
    
réponse donnée Hansu 16.01.2018 - 01:24
-1

Voici comment mon problème a été résolu.

Étape 1: Accédez à Cpanel
Étape 2: Cliquez sur "Gestionnaire de fichiers"
Étape 3: Ouvrez "Wp-config.php" en mode édition.
Étape 4: Collez cette ligne define('WP_HTTP_BLOCK_EXTERNAL', false); à la fin. Étape 5: enregistrer le fichier

Vérifiez maintenant votre http://yourdomain.com/wp-admin/ Dashboard - j’imagine qu’il sera corrigé.

    
réponse donnée Harkesh Singh Chauhan 16.01.2018 - 22:30

Lire d'autres questions sur les étiquettes