Wordpress a ajouté automatiquement “& nbsp;”?

11

Je ne sais pas si c'est wordpress lui-même ou Tiny MCE qui le fait. Mais lors du basculement entre HTML et Visual editor, il faut ajouter   et en ajouter un supplémentaire à chaque fois que je change de place. Je n'ai même pas de saut de ligne dans le code, il semble en quelque sorte décider où il veut les placer en fonction des balises de mon code html.

Quelle en est la cause et comment puis-je y remédier?

J'ai déjà essayé ceci dans le fichier de fonctions de modèle:

//disable auto p
remove_filter ('the_content', 'wpautop');
remove_filter ('comment_text', 'wpautop');
// Remove auto formatting
remove_filter('the_content', 'wptexturize');
remove_filter('comment_text', 'wptexturize');
remove_filter('the_title', 'wptexturize');
    
posée Dave 27.09.2011 - 21:54

5 réponses

2

Tout ce que j'utilise, c'est remove_filter( 'the_content', 'wpautop' ); remove_filter( 'the_excerpt', 'wpautop' ); et cela empêche Wordpress de créer des balises supplémentaires. Est-ce que vous copiez et collez votre code depuis un éditeur externe?

    
réponse donnée Matthew Xerri 28.09.2011 - 14:54
4

J'ai constaté que des espaces insécables sont insérés lorsque j'utilise deux espaces après une période. L'éditeur semble interpréter cet espace supplémentaire comme une tentative de ma part d'utiliser des espaces pour la mise en forme du texte.

Si je copie-colle mon article de l'éditeur Wordpress dans un éditeur de texte prenant en charge l'affichage hexagonal (j'utilise EditPad Pro), je vois que le texte que je pensais être un point suivi de deux espaces est en réalité un texte suivi par un espace, suivi du caractère Unicode avec le code hexadécimal A0, qui est le code Unicode NO- BREAK SPACE caractère.

J'ai pu supprimer l'espace insécable des articles existants en remplaçant l'espace suivi du caractère NO_BREAK SPACE par un espace uniquement. Dans la plupart des éditeurs de texte, vous devriez pouvoir le faire avec search & remplacez-le en copiant les "deux espaces" dans la zone de texte Rechercher et en écrivant un seul dans la zone de texte Remplacer.

J'ai pu éviter le problème à l'avenir en ne tapant qu'un seul espace après un point.

    
réponse donnée Eric J. 24.11.2015 - 05:32
3
  

Quelle en est la cause et comment puis-je y remédier?

Tout contenu ajouté ou supprimé de votre contenu de publication est provoqué par tiny_mce_init , qui applique ses règles de filtrage du contenu.

Les moyens de l’empêcher sont les suivants:

  1. Filtre tiny_mce_init , pour remplacer les règles de filtrage de contenu par défaut
  2. Arrêtez de basculer entre les éditeurs Visual et HTML . Vraiment; à moins que vous ne souhaitiez utiliser l'option 1 ci-dessus, ne changez pas d'éditeur . WordPress est conçu pour être utilisé de telle sorte que le contenu soit entré à l'aide de l'éditeur Visual ou HTML , mais pas les deux simultanément.

Exemple d'utilisation du filtre tiny_mce_before_init dans le Codex. Autre exemple de configuration / personnalisation de TinyMCE dans le Codex ici .

    
réponse donnée Chip Bennett 28.09.2011 - 16:40
1

J'utilise Wordpress pour un blog en hébreu.

Solution de contournement: Copiez le texte dans un éditeur tel que sublime ou notepad ++, puis recherchez et remplacez-le par des espaces normaux. Vous pouvez en copier un du texte.

Avertissement: ce n’est pas vraiment une solution, mais plutôt une solution de contournement, alors n'hésitez pas à voter. Pour moi, Wordpress ajoute avec joie nbsp partout et sans rime ni raison. Pas sûr de ce qui le cause. Cela se produit beaucoup avec le texte hébreu, beaucoup plus qu'avec un texte anglais.

    
réponse donnée wolfdawn 21.01.2018 - 20:38
-1

Dans le fichier css. Placez display: inline-flex dans le p dans the excerpt . Les espaces blancs supplémentaires ne sont plus gênants. travaille pour moi

    
réponse donnée Victor Montes de Oca 16.12.2013 - 11:20

Lire d'autres questions sur les étiquettes