Liens symboliques sur la boîte de développement avec plugins et feuilles de style

11

J'utilise mac os x 10.6 avec xampp.

http://wp3.1/ est l'URL où WordPress est installé.

Le chemin physique est /Users/myUserName/Sites/wp3.1/

Je n’installe pas de plug-ins ou de thèmes de manière "naturelle". J'ai créé un répertoire nommé "git" situé dans /Users/myUserName/git/ . C’est là que vivent tous mes dépôts git. Lorsque je veux installer un plugin, je crée simplement un lien symbolique dans /Users/myUserName/Sites/wp3.1/wp-content/plugins/ . Cela fonctionne très bien pour les plugins simples, mais si le plugin met en file d'attente une feuille de style ou un script, l'URL s'affiche comme suit:

http://wp3.1/wp-content/plugins/Users/myUserName/git/options-framework-plugin/css/colorpicker.css?ver=3.1.1

Comment résoudre ce problème?

    
posée mfields 24.04.2011 - 02:38

2 réponses

10

Les liens symboliques sont… à risque dans WordPress. Il est plus facile d’utiliser un domaine séparé pour les plugins par wp-config.php:

define( 'WP_PLUGIN_DIR', '/local/path/to/plugin/directory' );
define( 'WP_PLUGIN_URL', 'http://plugins.dev');

Voir Strategy On Building Plugin en utilisant Eclipse à titre d'exemple pour la configuration de l'EDI avec une telle configuration.

    
réponse donnée fuxia 24.04.2011 - 02:48
0

Comme vous pouvez le constater, l’URL du plug-in est correct, à l’exception du chemin réel bloqué au milieu. Nous pouvons filtrer la fonction responsable de la génération des URL de plug-ins et la supprimer.

Le code suivant doit être installé en tant que doit utiliser le plug-in :

add_filter( 'plugins_url', function( $url ) {
    return str_replace( '/Users/myUserName/git/', '', $url );
});
    
réponse donnée shea 20.08.2013 - 11:48

Lire d'autres questions sur les étiquettes