wordpress sur la lampe localhost ne me permet pas d'installer des plugins

15

J'ai installé un serveur LAMP sur mon Ubunutu 11.04. J'ai installé Wordpress et l'ai bien connecté avec la base de données MySQL. J'ai changé les autorisations du groupe www-data pour lire et écrire des fichiers.

tout semble fonctionner et je peux gérer le site via le panneau d'administration, mais je ne peux pas installer de plug-in car le système me demande les détails FTP, et je n'arrive pas à le parcourir.

n'importe quel corps peut-il aider? s'il vous plait ...

    
posée Asaf Chertkoff 10.06.2011 - 01:14

9 réponses

0

Je fais généralement cela quand cela se produit (uniquement localement, pas pour la production):

chown -R nobody:nobody /path/to/wordpress
    
réponse donnée mike23 10.06.2011 - 13:07
45

La solution que j'ai trouvée qui fonctionnait sur mon Mac exécutant Apache2 intégré consistait à l'ajouter à "wp-config.php"

define('FS_METHOD','direct');

Conservez-le dans une configuration localhost ou dev et ne l'utilisez pas pour la production.

    
réponse donnée WolfieZero 27.02.2013 - 11:50
5

Ceci est un problème d'autorisations. wp-content / plugins doit être accessible en écriture à l'utilisateur du serveur Web.

    
réponse donnée anu 10.06.2011 - 11:26
1

Utilisateurs Ubuntu

Ajoutez simplement define('FS_METHOD','direct'); à wp-config.php et cela fonctionnera sur localhost. Assurez-vous simplement de ne pas l'ajouter à la version de production. Voir: codex.wordpress.org/Editing_wp-config.php

.     
réponse donnée Jahanzaib Aslam 17.06.2016 - 08:29
1

J'utilise habituellement:

  

sudo chown -R _www: _www / path / to / wordpress /

    
réponse donnée Ari Pratomo 21.07.2016 - 16:15
0

Si vous utilisez mod_php, passez à mod_suphp. Cela a fonctionné pour moi dans le passé.

Je ne sais pas quel paquet il sera listé comme dans Ubuntu, mais généralement c'est quelque part. Fonctionne dans Fedora.

    
réponse donnée Otto 10.06.2011 - 17:56
0

Vous avez besoin de deux choses à faire

  1. Ajouter WolfieZero a dit

    define ('FS_METHOD', 'direct'); dans le fichier wp-config.php

À ce stade, vous aurez la suite suivante, laquelle un pas en avant

Déballer le package… Impossible de créer le répertoire.

2 Then set permission to 777 to wp-content/plugins

Après cela, un message s'affichera comme suit

Downloading install package from https://downloads.wordpress.org/theme/exclusive.1.0.32.zip…

 Unpacking the package…
 Installing the theme…
 Successfully installed the theme Exclusive 1.0.32.

CHOWN devrait également fonctionner et il est préférable de le faire si le serveur appartient au groupe de propriétaires.

    
réponse donnée vimal krishna 15.09.2015 - 10:27
-1

Ce n'est pas un problème de WordPress. Vous devez vous reporter à la documentation du serveur LAMP pour vérifier les options de configuration.

Pour localhost, vous pouvez ignorer l’installation de plugins à partir de WordPress et simplement copier vos plugins dans / wp-content / plugins. Une fois que vous les avez copiés, allez dans votre administration WordPress et ils apparaîtront dans vos plugins prêts à être activés.

Assurez-vous de décompresser les plug-ins et de les conserver dans leurs dossiers.

    
réponse donnée Elpie 10.06.2011 - 06:02
-1

Je ne sais pas si vous avez une réponse ... mais ce que j'ai rencontré, en particulier lorsque je travaillais sur Linux et que je pensais que d'autres utilisateurs, surtout ceux qui travaillent sur Linux, pourraient trouver cela utile. Je faisais face au même problème ... mais je devais utiliser l'option SSH2.

Comment installer SSH2

apt-get install openssh-server libssh2-php

Après cela, je devais redémarrer mon serveur apache2.

Puis, quand j'ai essayé de télécharger mon thème, je devais utiliser SSH et non FTP quand on me demandait des informations d'identification.

E.g

 Hostname: localhost

 FTP/SSH Username: admin

 FTP/SSH Password: password

Et cela a fonctionné.

Merci.

    
réponse donnée Samson 'Melah' Nyabanga 20.06.2016 - 11:08

Lire d'autres questions sur les étiquettes